一分钟跑通 Demo

最近更新时间:2021-07-08 01:48:25

本文主要介绍如何快速运行 RTM flutter Demo 。本文以 Android Studio 为例来具体介绍。

开发环境要求

如果你的目标平台为 Android,你的开发环境需要满足以下要求:

  • Flutter 1.0.0 或更高版本
  • macOS操作系统或 Windows 操作系统
  • Android Studio 3.0 或以上版本。
  • 一个有效的 开发者账号

如果你的目标平台为 iOS,你的开发环境需要满足以下要求:

  • Flutter 1.0.0 或更高版本
  • macOS 操作系统
  • Xcode 9.0 或以上版本
  • 一个有效的 开发者账号

运行环境要求

  • 如果你的目标平台为 Android,你需要有一台 Android 真机。
  • 如果你的目标平台为 iOS,你需要有一台 iOS 的真机。

前提条件

操作流程

1.下载 SDK 和 Demo 源码

前往 GitHub 下载最新的 SDK 以及示例项目。

2.配置 APP ID

打开下载的 Demo 工程,替换example/lib/main.dart文件中的 <APP_ID> 字段。

_client =
    await ARRtmClient.createInstance("<APP_ID>");

3.编译运行

  1. 在项目根目录运行以下命令安装依赖项。
  flutter packages get
  1. 运行项目。
flutter run